2009年11月29日

gccでsse

gccでintrinsic命令を使ってSSEプログラミングをする場合、gccのバージョンに注意が必要である。(当たり前だが)古いgccでは最近のSSE命令を使うことができない。




CPU対応するgcc必要なoption必要なヘッダ
MMXMMX Pentiummmintrin.h
SSEPentium3xmmintrin.h
SSE2Pentium4emmintrin.h
SSE3Pentium4 Prescottpmmintrin.h
SSSE3Coretmmintrin.h
SSE4Aammintrin.h
SSE4.1Core2 Penryngcc 4.3.0-msse4.1smmintrin.h
SSE4.2Core2gcc 4.3.0-msse4.2nmmintrin.h
SSE5bmmintrin.h



にほんブログ村 為替ブログ マイナー通貨へ にほんブログ村 サラリーマン日記ブログへ
posted by 絵の具 at 14:34 | Comment(0) | 日記 | このブログの読者になる | 更新情報をチェックする
この記事へのコメント
コメントを書く
お名前:

メールアドレス:

ホームページアドレス:

コメント:

×

この広告は180日以上新しい記事の投稿がないブログに表示されております。